Wednesday, May 12, 2010

Fixing the error in installing Maven plugin in Netbeans 6.8

I yesterday installed Ubuntu family newest OS release Ubuntu Lucid Lynx (Ubuntu 10.04) and then gone through the step of installing softwares. (Tried upgrade option of Ubuntu from Karmic Koala, but got screwed up! anyway it's another story.)
Ubuntu Lucid comes with Netbeans version 6.8. But there's a bug in it which prevents users from installing Maven plugin in it. It gives an error saying,
 Some plugins require plugin Utilities API to be installed. The plugin Utilities API is requested in version >= 8.0 but only 7.31.1.1 was found.

 This is a bug Netbeans and it is reported in Launchpad. Luckily, a workaround is available. It's listed under #2. What you have to do is,
1. Click on "Settings" tab in "Plugins"
2. Activate "NetBeans" (if not activated) and deactivate "Ubuntu Specific" (or "NetBeans for Ubuntu" in case of 6.8-0ubuntu4)
3. Go back to "Available Plugins" and Reload the catalog.
4. Then install Maven.